Crystal Reports 2011-Problema ao alterar configuração da página

11 04 2012

Hoje, ao tentar editar as configurações de página, de um mapa do Crystal Reports, deparei-me com um problema estranho que me impedia de prosseguir com as alterações que queria fazer num mapa de etiquetas de artigos, nas margens da impressão A4.

 

1

 

Após aceder à janela da Configuração de página, e editar qualquer um dos quatro campos da margem (não testei com a orientação, nem com as opções da impressora e página), a janela ficava “invisível” e o seu conteúdo desaparecia. Embora fosse possível, com a tecla do TAB saltar entre os campos, e verificar que o cursor chegava ao OK para gravar, se voltasse a mesma janela novamente, observava que as configurações anteriormente definidas tinham desaparecido.

4

2

Depois de testar a mesma operação num outro computador, o problema persistia. Após passar a fase inicial onde o habitual “fechar tudo, reiniciar o computador  e voltar a tentar” poderia resolver (e resolve em muitas situações), passei para a fase de investigar a origem do problema porque de facto não tinha alternativa.

3

A conclusão a que cheguei é que o problema estaria na unidade de medida, que por defeito está em Pixeis, e por alguma razão que desconheço provocava o problema inicial. Bastou alterar a unidade para Polegadas ou Centímetros e consegui gravar as alterações que pretendia com sucesso.

 

 

 

Cenário em que se verificou o problema:

  • Sap Crystal Reports 14.0.0.760 RTM
  • Windows XP SP3 PT, com configurações regionais para Portugal

Ações

Information

11 responses

16 05 2012
Pedro

Estava a tentar editar o ficheiro GCPVLS01.rpt do Primavera 7 Express na demo do Crystal Reports 2011 SP2, mas quando o abro no Crystal Reports ele diz-me que houve falha na compilação de uma ou mais formulas, assim como quando o tento visualizar também no Crystal Reports dá-me uma mensagem de erro do tipo “O ) está ausente”!
Algumem me pode dizer qual é o problema? Estou a utilizar o Win7 Home Premium 64-bit em português.

Obrigado.

17 05 2012
XpecialGUEST

Boa noite, reponha o mapa original e volte a fazer as alterações. Se tem a certeza que não alterou nada que possa estar a originar essa mensagem, grave na mesma, com esse erro. Quanto à pré-visualização do mapa, penso que para funcionar, é necessário antes fazer a ligação ao servidor de dados.

Carlos

16 05 2012
Pedro

Se abrir o mapa com a demo da versão 2008 do Crystal Reports (utilizei para editar os mapas do Primavera Express 6.40) ele diz que a versão deste é anterior à do mapa do Primavera 7 Express!

Se abrir o mapa com a demo do Crystal Reports 2011 SP2, ele diz-me que o mapa é de uma versão mais antiga que o C.R. 2011 SP2?!!

Alguém me sabe dizer qual a versão ao certo do C.R. em que os mapas do PE 7 Express foram criados?
Obrigado.

17 05 2012
XpecialGUEST

Penso que com o Crystal Reports 11. Utilize a última versão do C.R. ignore a mensagem que ele mostra sobre a versão do mapa, uma vez que apenas informa com que versão poderá alterar o mapa, posteriormente.

Carlos

22 05 2012
Pedro

Ok vou experimentar então com o C.R. 11 e depois testá-lo no PE 7.50.

25 05 2012
Pedro

Sim deu bem no PE7, apesar das mensagens de aviso iniciais do C.R. 11 SP2 Demo sobre algumas formulas não poderem ser processadas aquando da abertura dos mapas!

Só mais uma questão… se eu pretender migrar para o Primavera Easy Starter, sabem-me dizer se os mapas de origem do Primavera 7 Express são os mesmos existentes no Pimavera Easy Starter?

Obrigado.

25 05 2012
XpecialGUEST

Penso que os mapas são os mesmos. Confirme com a Primavera.

Cumprimentos

30 06 2012
Hugo Santos

Boa tarde, sou um utilizador do primavera express v6 desde 2011. Tenho seguido os seus tópicos com bastante interesse, e junto-me aos agradecimentos que aqui tem sido prestados pelo seu serviço publico.
No seguimento de um tópico para inserir logo e introduzir elementos, estou a tentar instalar a versão gartuita para download gratuita (v11). No entanto não consigo correr o ficheiro exe de instalação. Pode-me ajudar?

2 07 2012
XpecialGUEST

Boa tarde,

Qual o problema em concreto? É gerado algum erro?

Cumprimentos
Carlos

20 01 2013
Fernando Rodrigues

Boa noite.
Tinha a versão 6.40 a funcionar onde fiz alterações com o CR anterior e tudo correu bem! Agora com a nova versão 7.5 do PE e o CRXI não consigo que o CRXI me apareça e lado nenhum apesar de estar nos programas instalados nos PCs , pois estou a fazer testes em 2 pc’s embora com as mesmas versões de Win XP SP3. Também se imprimir documento sem logo aparece numa linha, que é cópia do documento original FTM2013…. o que penso que não é válido de todo! Já instalei e reinstalei os pacotes mencionados do CristalXI.RDC.EXE e o CrystalXI.Net.msi…
Se me puderem elucidar mais um pouco agradecia!

Continuem com o bom trabalho!

31 01 2013
XpecialGUEST

O seu comentário não é claro. Em todo o caso deverá utilizar sempre a última versão da aplicação (opção “Procurar actualizações” no menu Ajuda), e a última versão dos mapas (https://invisibleflamelight.wordpress.com/2013/01/19/crystal-reports-inserir-comentrios-nos-reports/). Para alterar os mapas necessita do Crystal Reports.
Cumprimentos

Deixe uma Resposta

Preencha os seus detalhes abaixo ou clique num ícone para iniciar sessão:

Logótipo da WordPress.com

Está a comentar usando a sua conta WordPress.com Terminar Sessão / Alterar )

Imagem do Twitter

Está a comentar usando a sua conta Twitter Terminar Sessão / Alterar )

Facebook photo

Está a comentar usando a sua conta Facebook Terminar Sessão / Alterar )

Google+ photo

Está a comentar usando a sua conta Google+ Terminar Sessão / Alterar )

Connecting to %s




%d bloggers like this: